読者です 読者をやめる 読者になる 読者になる

ruby最新開発版のビルド

いろんなレポジトリがあるみたい。必要なものはautoconfとmakeとsubversionか。

$ uname -a
Darwin san.local 8.10.1 Darwin Kernel Version 8.10.1: Wed May 23 16:33:00 PDT 2007; root:xnu-792.22.5~1/RELEASE_I386 i386 i386
$ svn co http://svn.ruby-lang.org/repos/ruby/trunk ruby-head
...
$ cd ruby-head
$ autoconf
...
$ ./configure
$ make